01/18/19

解决owncloud 在wdcp环境下出现重定向循环过多的问题

由于前段时间挂载一个新的硬盘出错,自己吧vps重新安装了一下 当时一时间大脑发热就安装了wdcp面板, 因为wdcp搭建的环境支持Nginx+Apache双web 存在一定的不兼容性问题,同时wdcp3.3存在的BUG问题也是非常之多. 我的页面错误提示如下: 重定向过多,无法打开网页,重定向循环…….当然不同浏览器下是有不同报错的。 我当时以为是浏览器的问题,重启清空了cookies也还是不行。 产生错误的原因主要是因为: 1、wdcp3.3,在使用Nginx+Apache模式下,默认的php版本是5.53,这个时候提示重定向过多,网页无法打开。 2、因为不知道到底是Apache出了问题,还是Nginx出了问题。      

06/23/15

在wdcp集成面板下安装phpwind9.01的方法

其实很多云主机安装phpwind9.01是非常简单的。但是由于很多人现在为了更多的DIY,说白了,就是喜欢玩的更花哨一点大多选择VPS。 在VPS面板中,WDCP是用户使用量比较大的国内VPS面板,相比较AMH可能还多一些,存在这样的主要原因一来是时间久,二来是文档多,如果遇到问题或者环境的升级等基本都可以找到解决方案。 WDCP环境配置需要升级PHP以及需要安装PDO_MYSQL组件支持的时候,发现有这样需要将WDCP默认环境升级PHP版本的比较多。 phpwind9.01之后的版本可以直接生成手机平台客户端,这就给予了广大用户升级的力量。 phpwind9.01除了以前需要的环境外,很多环境都需要更好的配置,例如php的版本需要5.3,还需要安装PDO_MYSQL,还要有服务器SSL权限 shikey无聊的时候也升级了一下,并且成功安装了phpwind9.01,并且生成了移动客户端,下面是我安装的步骤。 1、php集成包。默认的WDCP面板安装,PHP版本是5.2.17,如果需要升级PHP5.3或者是5.5则需要通过升级的方式,这个方法相比较网上的其他方法能够节省很多时间。 A、升级PHP5.3 wget